Factory Five Racing Forum banner
1 - 6 of 6 Posts

· Junior Charter Member
Joined
·
249 Posts
Mine sat for almost 2 yrs before installation. I opened it once during that time to have a look because I was curious. It was still wet from assembly lube. Its sealed very well with some black goop that is so strong it might hold up an elephant. Well, not really but its very strong. Ha, just had to add some humor, its been a very good day.

I didn't fill it until it was installed. Don't forget to put the yoke in if you don't have a driveshaft ready if you fill it. I strongly suggest to bag it to keep the dirt/dust off.
 

· Premium Member
Joined
·
3,886 Posts
Also, unless you have an extra yoke (or something similar), if it's full when you install it a lot of fluid will leak out during installation.
 

· Junior Charter Member
Joined
·
2,087 Posts
I could not get mine in with the mid-shift shifter installed. So since you need to install the shifter after installation, it is easier to just fill it from the shifter hole after engine install. Take the level check plug out of the right side 1st so it is ready to fill once installed.
 

· Registered
Joined
·
3,619 Posts
Got mine new from Mike at Fortes and it came with a plug around the output shaft that had to be removed. I had it about 6 months before I installed it and it has been fine. My take on this is when they are made they close them up for shipping and the trans may be in stock for awhile before it is sold. I do not think you have a problem unless you store it outside in the rain.
CB
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top