Factory Five Racing Forum banner
1 - 6 of 6 Posts

·
Delivered 05/11/07
Joined
·
54 Posts
Discussion Starter · #1 ·
It seems like everything has been together and then apart three times each but now I am getting ready for the final torqueing (maybe optimist), who knows!

Thanks
 

·
Premium Member
Joined
·
6,598 Posts
I would replace every locknut that was used more than once or twice.

I also put Red Locktite between the upper ball joint and upper A-arm bracket.

I also put on Blue locktite on the Spindle bracket (with 2 or 3 holes)

I put blue locktite on the UCA to chassis bolts.

The rest I just torqued down as needed without additives.

-Kouros
 

·
FFCobra Craftsman
Joined
·
24,740 Posts
I don't use loctite anywhere on the suspension.But I use either factory type or nylock nuts on everything.
 

·
Premium Member
Joined
·
4,531 Posts
I really like safety wire. It's used extensively in my line of work. Not sure how much it will be incorperated into my initial build, but it'll end up with some before it is over.

One thing I have noticed with my kit is the lack of proper thread protrusion through nuts.
The 3 link lower shock mount bolts are too short. Front upper shock mounts are as well.
 

·
FFCobra Master Craftsman
Joined
·
8,694 Posts
I used loctite RED on the steering shaft connection to the rack. This is the one bolt that I do not want to come loose.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top