Factory Five Racing Forum banner
1 - 2 of 2 Posts

·
Moderator
Joined
·
6,333 Posts
I'll try to help you if I can. I don't know if the Classic Instrument gauges are mechanical or electric but I have Autometer 427 gauges which are mechanical and the same box heater mounted to the left of the dash support(so I could get a glovebox in). I had to re-arrange my dash layout a couple of time until I got one that worked. The sending unit tubes will only fit in certain spots. I also had to do some filing on the retaining nuts so they would clear. I think I even shortend a mounting post or two also. Once you get the dash covering on that will help a little as it moves the dash away from the dash hoop just a bit. Everything looks good now. Just keep reminding yourself, there's no extra room for anything in these cars and you'll be okay.
Frank
Frank
 

·
Moderator
Joined
·
6,333 Posts
Bobbit,
Sorry for the misleading response. It just occurred to me that the heater from Tri-States is intended to be installed between the dash and the firewall(hidden from view). I have the same heater but got it from Whitby's and as such it comes with some pieces of angle aluminum so you install it about 2/3rds behind the firewall and 1/3 in the engine compartment. The Tri-States heater is supposed to install to the right of the vertical dash brace so you get no glovebox. Since you've already got two holes cut in the firewall you're kind of stuck. Either take it out and plug the holes or open the firewall and push the heater into the engine compartment.
Frank
 
1 - 2 of 2 Posts
Top