Factory Five Racing Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #1
My S&W gauges are giving me fits. My oil temp shoots up to 270 within a minute or two of run time, yet I can pull the dipstick and the oil is hardly warm. At this point My H2O gage is still running below 100 degrees. At first I thought I may have switched wires between the two gauges, but I checked all of my connections and everything was kosher. I have heard of other problems with the S&W gauges, is this typical?

Karl
 

·
FFCobra Fanatic
Joined
·
5,514 Posts
Typical....
If I had known they were going to supply me with electric gauges instead of mechanical, I would have purchased something else. I ended up buying a mechanical water temp gauge instead of the electric deal. My oil temp gauge seems to do what yours does. Recently I bought a set of Autometer Smith replicas to replace the SW's and hopefully they will be a little more accurate and dependable. Good Luck!

Mike
 

·
Charter Member
Joined
·
99 Posts
Karl,
Could you have possibly inadvertly swapped the two senders . I have the sw gauges and remember the two senders looking almost identical! Something to check before you fork out mo money
.............COBR 65
 

·
Registered
Joined
·
283 Posts
Discussion Starter #4
Mike & Jeff,

Thanks for the response. I went crazy trying to figure out if I swapped the senders. As I understand it from the instructions the sender for the water is a one piece unit with a 1/2" pipe thread. The oil is much smaller and threads into a 1/2" adapter. Is this correct?

Mike, are the Autometer Smith replicas the same size -- do they fit your existing holes?

Thanks!

Karl
 

·
Registered
Joined
·
283 Posts
Discussion Starter #5
Just for kicks, let's see how big of a dufus I am (I can be a pretty big one sometimes). My sendors have to following part numbers on them (which are not even close to what FFR tells me they are in the instructions):

Water Temp 334-J
Oil Temp 334-H

My instructions call out a 280ED-F (Water) and a 280EE-F (Oil), but I've got nuthin' like that.

Thanks,

Karl
 

·
FFCobra Fanatic
Joined
·
5,514 Posts
I am changing my whole dash...going to the Competition layout. If you had gotten the dash from FFR for Mustang gauges, the Autometers fit right in there. Oh well, best laid plans!!
I am going to make my own dash, FFR gets $75 for a blank dash I think. Cant be that hard! Then my whole dash will be for sale on the forum. Good Luck with it!

Mike
 

·
Registered
Joined
·
428 Posts
Just checked, my oil sender is the 280ed-f to be installed this winter. My water temp. has been right on all summer 3200 miles. Maybe you got the wrong senders? I'd call FFR and find out if they changed senders. Good luck!
 

·
Registered
Joined
·
283 Posts
Discussion Starter #8
I was hoping I would be the big dufus and just swap the sending units. I will be checking with FFR.

Thanks for the help!

Karl
 

·
Registered
Joined
·
355 Posts
We've got the SW Wings gauges. The problems were having are with the Speedo & Tach. The tach isn't always accurate we can just be at idle and the tach jumps to 3k, rev it up and the tach goes up but still out of sink. The speedo don't always work. At first I thought a bad connection (electric) but the odometer still turns over.
 

·
Senior Member
Joined
·
1,018 Posts
I have SW gauges and have the 334-J for oil and 334-H for H2O. They work fine for over a year now. I think you have the senders reversed.

Doug
FFR2625
 

·
Registered
Joined
·
283 Posts
Discussion Starter #11
Doug,

Thanks! That is the simplest solution to my problem. Appreciate the help.

Karl
 

·
Registered
Joined
·
635 Posts
I've got SW gauges and they suck. If it's not too late I would see about returning them. I've had nothing but trouble with mine and the tach and water temp gauges are very inaccurate. I need to get a new set of gauges but just don't have the funds right now.
 

·
Official Member of the Unofficial "First 500 Club"
Joined
·
3,007 Posts
Yep they suck. My tach is off at least 50% of the time, they fog up, I've replaced the speedo after snapping two speedo cables.

I plan on upgrading to the Autometer Smith copies, but I really like the electric gauges. I'm not big on having an oil line running into my interior, regardless of how much more accurate it is. I don't think the Autometer Smith's are available as electric, and I would have to buy another fuel tank sender ($75), so I am not sure when I will do it.
 
1 - 13 of 13 Posts
Top