Factory Five Racing Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Hey guys, from a builder that is not prematurely Gray. Just a FYI. Have a Gen 2 Daytona. Windsor 351. Pro Comp. Al. heads, mild Cam, 670 Holley and MSD 6al, distributor and coil. Engine ran fine during the break in period as I kept the RPM's below 3000 rpm. As I started to get a little more aggressive on the throttle, the Engine would "Stumble" then accelerate to about 4500 rpm and then stumble again. Thought that it was going "Rich" Dropped the secondary Jets down two size, performance improved but still would stumble as the secondary's opened. Stepped the Primary's down two sizes thinking that it was "Rich" before the secondary's opened. No help. This condition only became worse as I added miles. Would "Pop an Burble" during acceleration and deceleration. Timing and fuel pressure were spot on! Decided that maybe the Spark Plugs were fouled and needed replacement. I was using the Autolite # 25 Plug that was recommended by a local Hot Rod Shop. Checking with my good friend David at Bent Motor Sports in San Marcos Ca. (Sorry - He is a Jeep Guy and only helps because of our long friendship) discovered that there were numerous Sparks Plugs available, but with different lengths. After taking measurements from the Top of the Cylinder Head plug hole to the bottom of the Cylinder, David noticed that the #25 Plug was not even into the combustion chamber!
Replaced the Plugs with a proper length plug, rejetted the Carburetor to factory spec's. Results: If you can reach the $100.00 Bill I have taped to the Dash before I get out of 4th gear? It's yours!
 

·
Senior Charter Member
Joined
·
939 Posts
HA ! great story and results of doing it the right way vs. what someone said should work. Enjoy!
 
1 - 2 of 2 Posts
Top