Factory Five Racing Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
Put the body on today, the rear of car was sitting to low.I cut the rear coils as the manual said to do,now when i turn the coils down to raise the rear it looks like i don't have enough coil left at the top to keep the coils in the holders safely. Any one else have this problem,i have the Mark 2 kit. Thanks for help.
 

·
Registered
Joined
·
500 Posts
I have the cut on my coils even with the top of the frame spiral thingy. I know thats not the TECH name for it! My ride height is 26 3/4" my tires are 25" tall. I had an issue with a strange noise when going thru small dips in the road before, now, no problem and the ride looks and feels great! No squatting problems.
Rick
 

·
Banned
Joined
·
333 Posts
Either the Mark II must be a little different or your springs are shorter than mine. I have my rear height set at 5" and I still have almost a whole coil left at the top. How much did you cut off?
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #6 ·
AJ I was thinking i should order new springs from Five Star and not cut them, but lightning says his are even with the bottom of the round mount and has not had any problems. Anyone else have any thoughts on the rear coils? Andy
 

·
Senior Charter Member
Joined
·
458 Posts
I have my rear pretty low... 4.5" on a MK II chassis with the stock rear springs that I cut about 90% of one coil out.

I have a good deal of overlap... not sure how much, bit quite a bit extra.
 
1 - 7 of 7 Posts
Top