Factory Five Racing Forum banner

1 - 7 of 7 Posts

·
Owner
Joined
·
343 Posts
I am running a Big Block FE, using an Odyssey. First one was a 920 and it worked fine but if you had any issues, it would run out of umph. When it shot craps (6 yrs), I replaced it with a 1200. Works great.

I was running Webers and it would handle hot-starts without issues. Now running EightStack Injection and it starts first time, every time. Battery has never been an issue.

Paul
 

·
Registered
Joined
·
307 Posts
In my MKII with a 302, I ended up going with an Odyssey PC925. Mainly because it fix my battery location under the trunk. It was only been 1.5 years now, but I have been very satisfied with it. I have had no issues at all. For a glorified motorcycle battery, it has been fantastic. My car starts in 20F and in 116F with no issues. I dry my car at least monthly, but even so, it has never been close to low.
 

·
Registered
Joined
·
5,924 Posts
Not a Roadster, but still counts? I have an Odyssey PC925T in my Gen 3 Coupe. Front mounted where Factory Five has the Gen 3 Coupe battery. Only done and driving this season, but so far all good. Spins and starts the Coyote with ease. Zero issues.

 

·
Registered
Joined
·
1,578 Posts
I used the PC1200 in my MKIV. Trunk mounted in FFMetal Battery box. The battery is smaller than standard battery, so I needed to make a base from plywood routed out to fit the battery. Used it for 5 years, then sold the car in 2018. To the best of my knowledge, the 2nd owner has not replaced it. I will be using one in my next project.
 
1 - 7 of 7 Posts
Top