Factory Five Racing Forum banner

1 - 5 of 5 Posts

·
OK, I'm In!
Joined
·
227 Posts
Discussion Starter #1
OK guys, been a while since I've posted....Need your expert help.

In the 6 years I've own the Cobra it's run just fine. Worse problem I had was a throttle cable that snapped.

I just sold it a few weeks ago, but I still have it in my possession trying to iron out some issues it just started having.

The engine is a Ford 302 w/ a Holley 670.

So I meet the buyer & we do the title transfer & all & when he comes back from a drive around the block & goes start it again it wont crank, battery seems low. We get a jump & it starts right up, but he ask me to get him a new battery. Sure, no problem. On my way home with it (his car now), while at a light my tach starts jumping up & down like crazy & she just turns off. I though alternator maybe.....so I got another jump but this time it wont start. just turns & turns, but wont crank. So I think spark.....

I remove distributor cap & see that the rotor contact is worn & contacts on cap are all corroded. I tow it back home & order new MSD cap & rotor.

So yesterday & start it up & it's running ok. Did notice a small pop (misfire or backfire) at around 3000 rpms, but other than that it's running pretty good. I'm taking it to the buyers storage unit & 2 blocks away it just dies as I'm driving. I coast to the side of the road & again, she wont crank, engine just turns & turns.

I'm thinking that maybe the MSD Ignition control box is going bad. I tested it before, when I changed cap & rotor & I was getting spark from the coil & I also tested the magnetic pick up & although it's pretty rusty it was showing 580 ohms.

But I've been reading that those 6A MSD Boxes sometimes just up & die.

What do you guys think? Any opinions or help would be greatly appreciated. I want to give this gentleman a car running like it should be, so I need to get this fixed.

Thanks in advance
 

·
Junior Charter Member
Joined
·
221 Posts
Have you verified the magnetic pickup in the dizzy is good? I had this problem a year ago as I had no spark which started out very intermittent. MSD has good troubleshooting procedures on their website. it is an easy procedure to check. The magnetic pickup is something that is easily overlooked so a quick resistance (ohms) check can tell you if it is bad or possibly broken. Mine was broken in half.

HTH,

Gary
 

·
OK, I'm In!
Joined
·
227 Posts
Discussion Starter #4
Have you verified the magnetic pickup in the dizzy is good? I had this problem a year ago as I had no spark which started out very intermittent. MSD has good troubleshooting procedures on their website. it is an easy procedure to check. The magnetic pickup is something that is easily overlooked so a quick resistance (ohms) check can tell you if it is bad or possibly broken. Mine was broken in half.

HTH,

Gary
yeah, I did. Although it looks all rusty, it was showing about 580 ohms, which is right in the range MSD suggest.

yes MSD boxes do die. Sometimes slowly.

Dwight
I think that's what's happening.

BTW, PM replied :thumbup1:
 

·
Registered
Joined
·
2,607 Posts
1 - 5 of 5 Posts
Top