Factory Five Racing Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
I was in a Christmas parade with about thirty golf carts. I believe the heat from the engine compartment compromised the cable after about an hour of idling. Water temp stayed at 210, engine ran fine but the clutch pedal slipped down and quit disengaging the trans. If anyone has a spare setup up it may help in fixing it. Possibly a better part might be the way to go also. I will not know till my mechanic gets into it. Any advice from the ‘experts’ is well accepted. Happy new year to all.
Tire Wheel Car Vehicle Window
 

·
Registered
Joined
·
512 Posts
My Hot Rod has a hydraulic clutch system, but the Cobra has the 302, T5 with the clutch cable. My cable also went wonky after getting stuck in heavy traffic. I looked into switching to a hydraulic system for $800 or so, but went with the Forte clutch cable for $25. Actually, they are sold in pairs. It took me longer to get the car in the air than to replace the clutch cable. Afterwards, the car shifted like new.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
My Hot Rod has a hydraulic clutch system, but the Cobra has the 302, T5 with the clutch cable. My cable also went wonky after getting stuck in heavy traffic. I looked into switching to a hydraulic system for $800 or so, but went with the Forte clutch cable for $25. Actually, they are sold in pairs. It took me longer to get the car in the air than to replace the clutch cable. Afterwards, the car shifted like new.
Thanks for the reply. Sounds like low quality parts.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
thanks for all the responses. I decided to let the mechanic look it over and decide what cable is best. will update on condition of failed cable after the repair is done. sure miss driving the car.

Plant Tire Wheel Sky Vehicle
 
1 - 5 of 5 Posts
Top