Factory Five Racing Forum banner
1 - 8 of 8 Posts

·
Charter Member
Joined
·
1,558 Posts
Discussion Starter · #1 ·
4786 came to life this weekend but it is running very very rich. Any idea's. She has FMS X heads and an edelbrok intake with 24lb injectors and a mass. air conversion. Any idea's are welcome.
 

·
Orbiting FFCobra.com
Joined
·
778 Posts
Did you set the timing correctly?
 

·
Charter Member
Joined
·
1,558 Posts
Discussion Starter · #3 ·
Engine was shipped from a guy in Texas. It was removed and crated. I assumed the distributor was not touched
 

·
Registered
Joined
·
675 Posts
What indicates that it is running rich? Fumes? Spark plugs? The way it runs?

Mine made terrible fumes and stumbled off of idle. After checking the obvious (timing, idle setting, TPS) it turned out to be a C&L mass air sensor that worked like garbage. I installed the stock MAF and it runs great. Fumes are gone too.

Frustrating until you get it sorted out and then tons of fun once it is sorted out.
 

·
Male Member
Joined
·
1,873 Posts
Jim, it will run rich on initial start up. Leave the computer powered and after several times up to temp it will be OK. Just don't disconnect the puter or it will have to learn all over again. Also, check your TPS.
Jim
 

·
Charter Member
Joined
·
1,558 Posts
Discussion Starter · #7 ·
Jerry
How can I determine if the MAS is calibrated for 24lb injectors.


Craig,
The eye burning fumes and the way it runs.


Mr. Pink,
How rough should it run for the first few runs up to temp. Whats TPS?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top