Factory Five Racing Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter #1 (Edited)
New guy here, new guy to FFR. I purchased a partially complete Roadster from a guy in CO, hauled it clear back to the middle of Kansas. The Ford 302 engine is beautiful (enginefactory.com). I've got to the point of hooking up gauges and a thermostat for my electric fan on the radiator.

Can someone provide me some guidance on which ports on the block/intake to use for:

water temp (gauge reading)
water temp (thermostat kit from Summit Racing)
oil temp
oil pressure

I appreciate it!!
 

·
Non-supporting member
Joined
·
1,164 Posts
Shooter, I used this for my oil temp and pressure sensors.
http://www.maxspeed-motorsports.com/oilfilterplate.html

I used the port on the thermostat housing for my water temp sensor. On my Edelbrock intake, there is a port about 2 or 3 inches behind that you could use to tap into your water also. I'm not sure what your summit thermostat kit calls for in terms of how the temp is read.
My automatic fan controller has probe that goes in between the fins of my radiator that turns my fan off and on.
HTH, Web.
 

·
Senior Charter Member
Joined
·
568 Posts
Where are you in OP? I could probably come by some evening/weekend and point....

PM me if you are more comfortable

Bruce
 

·
Registered
Joined
·
197 Posts
Discussion Starter #4
That sandwich piece is pretty neat. Will it work with the alternate oil filter mount?

I'm in south OP, but my car is back in my hometown near Salina KS.
 

·
Non-supporting member
Joined
·
1,164 Posts
That sandwich piece is pretty neat. Will it work with the alternate oil filter mount?

I'm in south OP, but my car is back in my hometown near Salina KS.
It should work with it. Just curious, why are you using the remote mount? I've heard bad things about it cracking. The way mine is set up is all on the block. First I mounted Ford Racing 90 degree oil filter adapter (part number M-6880-A50) to the block and then the sandwich plate to it. Then the filter.
 

·
Registered
Joined
·
197 Posts
Discussion Starter #6
I bought the car partially assembled and it was already on the car. Hope it works...



It should work with it. Just curious, why are you using the remote mount? I've heard bad things about it cracking. The way mine is set up is all on the block. First I mounted Ford Racing 90 degree oil filter adapter (part number M-6880-A50) to the block and then the sandwich plate to it. Then the filter.
 

·
Registered
Joined
·
197 Posts
Discussion Starter #7
I got ahold of Robert at the enginefactory and he talked me thru the ports. Very knowledgeable!

Oil Pressure and oil temp can come off the same port - located on driver side, between oil filter and head. He suggested buying a nipple and tee at Home Depot and installing two sending units onto one port.

As for the water temp, there's a port right above the water neck and another on the driver side, pretty much below the ignition coil they installed.
 
1 - 7 of 7 Posts
Top