Factory Five Racing Forum banner
1 - 7 of 7 Posts

· Moderator
Joined
·
6,297 Posts
Discussion Starter · #1 ·
Gordon,
My car has been running great but the primary float bowl gasket was starting to leak so I popped a new one on. No problem..... so far. I always like to check myself for screwups so I switched on the fuel pump to check for leaks. A couple of seconds for the bowl to fill then a geyser of gasoline came shooting out of the primary vent. WTH????!!! Took it apart again, checked the float to see if it was fuel soaked, it's not. Pulled the needle and seat, and it looked like new, no ridge on the needle or any other deformations but I put a brand new one in just to be safe.

Button it all up, hit the key and gas comes shooting out the vent tube again. What am I missing here?
Thanks,
Frank
 

· Pro FFR Builder and Moderator
Joined
·
14,825 Posts
It sounds like the float is stuck on something. Check the mounting pin for the float. I have seen them jam from time to time.
 

· Moderator
Joined
·
6,297 Posts
Discussion Starter · #3 ·
It moved freely when I checked it but I'll look again. Something else that was very strange to me. When I pulled the bottom float bowl screw hardly any gas came out of the bowl. Normally it will almost fill the cup. Which begs the question, if the bowl isn't full why is gas shooting out the vent? I'll pull the float assembly to see if something in there is misdirecting the fuel.

Frank
 

· Administrator
Joined
·
6,612 Posts

· Moderator
Joined
·
6,297 Posts
Discussion Starter · #6 ·
I was hoping I could just quietly slink off without a public confession, but in the interests of education I'll give you a clue, don't put the power valve in backwards.
Frank
 

· Pro FFR Builder and Moderator
Joined
·
14,825 Posts
That would do it.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top