Factory Five Racing Forum banner
1 - 4 of 4 Posts

· Premium Member
Joined
·
2,915 Posts
Discussion Starter · #1 ·
I have the electric Classic gauges, and the fuel gauge that reads right from the Mustang sender. Usually it will read ok, but sometimes it reads totally full when it is not. The other thing is is that when driving around or reving it, the neddle sometimes moves. Also, it seems to read a 1/8 of a tank more than what is really in the tank. When used in the donor, the sender seemed to be alright. How can i fix these three problems?
Thanks
Eric

[ April 04, 2002, 04:40 PM: Message edited by: Eric 427 Shelby ]
 

· FFCobra Fanatic
Joined
·
1,997 Posts
I have the Classics and except for the needle moving around I'm not sure I can help you. The needle moving is due to the lack of the anti-slosh module. My gage will move during turns, braking, and acceleration as the gas gets sloshed in some direction but while driving on a level road it's OK. Beyond that, it's dead accurate. When it hits E it's empty! Not like a production car where E means you have about 30-40 miles to find a gas station. On mine, E means in about 2 minutes the engine's gonna quit!

The only thing I can think with your erratic reading is a bad connection, either signal or ground that's causing resistance changes.
 

· Registered
Joined
·
916 Posts
Ditto what Rick said. Mine appears to be dead nuts as far accuracy. It doesn't even "slosh" that much while turning or breaking, hardly noticeable.
I'd pull the sender and see if the float is hanging up on the mounting bracket.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top