Factory Five Racing Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Fired up the FFR supplied fan last night for the first time. Ran great for five minutes.....then a blade flew off! Took the unit off, the fan rotates fine with all other blades intact. Seems like a defect, but not sure its worth the hassle.
Should I replace 'in kind' or take the opportunity to go with something better
?
 

·
Heat & Beat Specialist
Joined
·
529 Posts
Get a fan with the ring around it. Summit sells a decent one for just a little over $100 shipped.
 

·
Senior Member
Joined
·
5,573 Posts
what the hell is the deal with these fans???? It can't be right that this happens so often. Everyone talks about there not being enough space and the blades coming into contact with the mounts but how many have to go this way before FF does something?

Can FFR chime in here?
 

·
FFCobra Fanatic
Joined
·
4,257 Posts
SpeedNeed,

Did you add spacers between the fan and those cross braces? That's what usually catches a blade and brakes it. The blades flex enough to catch it.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #6 ·
I did, but apparently not enough! When I disassembled the unit, I removed the spacers and set it back on...and the remainder of the blades still did not make any contact...so I tend to believe this one blade was slightly out of alignment or that it flexed more than the others under operation....
 

·
Orbiting FFCobra.com
Joined
·
778 Posts
When did you get your kit Speedneed? Just wondering the time frame so I can anticipate my fan breaking
That is if yours is indeed in the time when there was a defective batch of fans...

Mark
 

·
Registered
Joined
·
132 Posts
I had one of the blades come off within the first ten minutes of running the fan. Nothing was touching the blades.........one just flew off. The resulting vibration would shake the whole car. I cut off the blade opposite the one that came off and now have 1,700 trouble free, cool running miles on the car.
 

·
Senior Member
Joined
·
3,645 Posts
Mark- put a spacer on it or you'll be sorry....

putting the windshield and doors on Sunday afternoon if you want to come help button-her-up?
 

·
Senior Member
Joined
·
4,494 Posts
You have experience a typical SPAL fan failure. Often this also results in getting holes in the radiator. Get one of the swirl type fans that have a ring on them that connects the blade tips together. I recommend you DO NOT install another SPAL fan.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top