Factory Five Racing Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter · #1 ·
Hi guys,

Got a problem. My clutch cable snapped where it goes thru the bell housing. The cable was older but I'm still surprised it would shear off like that. What/where is the best place to get a new one. T5 transmission with a 302. Could I have missed something during installation that caused this? I only have 1000 miles on the car, but I do not know the history of the cable. Thanks!!
 

·
Premium Member
Joined
·
11,853 Posts
Most parts stores carry an inferior brand. Get a Ford or a Motor Mite Brand. They are the only ones I have found that are good. HTH, Cheers Richard.
 

·
Senior Charter Member
Joined
·
1,623 Posts
Had a similar problem yesterday, except I got all of 4800 miles on mine http://www.ffcars.com/ubb/ultimatebb.php/ubb/get_topic/f/1/t/097489.html
I diagnosed my problem as a misalignment with the clutch arm which caused flexing at the point the cable meets the ferrule. Since the clutch fork swings in an arc there has to be some accommodation for flexing but it shouldn't occur at that point. Mike Forte has a fix. Tell him I sent you.

Tom
 

·
FFCobra Master Craftsman
Joined
·
8,694 Posts
I looked at this part at the local Ford dealer and the price was approximately $148! Even the counter guy was surprised.

I bought my spare from Mike Forte. At his prices, it pays to buy two cables when you consider the shipping costs.

This is something that can be done on the side of the road in a pinch and regular inspection (something that I need to do more often) should help reveal the problem before it gets too bad.
 

·
Premium Member
Joined
·
9,134 Posts
Hi Sully,
I have OEM Ford cables for $45.00 or 2 for $50.00. What bellhousing are you using? Did the cable align with the fork or was the cable angled to the fork from the bellhousing?
Mike
 
1 - 6 of 6 Posts
Top