Factory Five Racing Forum banner
1 - 8 of 8 Posts

·
Senior Member
Joined
·
2,746 Posts
Discussion Starter · #1 ·
Guys,

Is there supposed to be some sort of retaining clip holding the clutch cable housing where it goes thru the bellhousing? I didn't take my donor apart, but I think I remember seeing one on an exploded drawing in my Chiltons for the Mustang.

Is there one needed? If so, what kind?

TIA,

Chris.
 

·
Premium Member
Joined
·
10,650 Posts
It is a U shaped clip with a rounded flange perpendicular to the U (best description I can come up with). I got mine from a Ford dealer.
 

·
Senior Member
Joined
·
2,746 Posts
Discussion Starter · #3 ·
Thanks Mark,

I'll get one from the local guys if I can.

CW
 

·
Junior Charter Member
Joined
·
289 Posts
Yep there is a clip. Mark described it pretty well!
 

·
Living Large
Joined
·
1,871 Posts
Chris,
I have a few extras I can mail you a couple if you can't find them.
Cheers,
Trent
 

·
FFCobra Craftsman
Joined
·
1,273 Posts
I used a small worm gear clamp. Works fine.
 

·
Senior Member
Joined
·
2,746 Posts
Discussion Starter · #7 ·
Thanks everyone for the speedy help as always.

Trent, thanks for your generous offer, I, hopefully can find one locally so you don't have to go to that trouble.

Chris.
 

·
Premium Member
Joined
·
18,135 Posts
You really don't need it unless you're using the stock cable and quadrant set up. And even then I'm not so sure you need it.

However, just do like Dave said and use a standard hose clamp.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top