Factory Five Racing Forum banner

1 - 8 of 8 Posts

·
FFCobra Craftsman
Joined
·
877 Posts
Discussion Starter · #1 ·
Has anyone had one of their catalytic converters brake? Here's a pic of mine that came apart. I had the Cat originally cut and rewelded to allow the sidepipes to exit the car properly, and that weld is fine. However, the thin metal of the Cat itself failed?



I hope I can get it welded back up. Do I need to go to a solid side support in place of the rubber one FFR instructs you to use from the Donor?
 

·
Uber-Geek
Joined
·
1,606 Posts
A solid side support would make things worse, not better. Your engine is *NOT* fixed in relation to your frame. (Unless of course you have solid mounts?) You bolt your pipes to the frame and they will be. Engine moves. Pipes don't. Bad juju.
 

·
Registered
Joined
·
45 Posts
Judging by the break (and not being privy to exactly how it mounts), it looks like that joint takes a fair load -- the combination of that and rust led to a failure?

Best of luck,

Filippo
 

·
Senior Member
Joined
·
1,018 Posts
I went a head and had my CATS ceramic coated along w/ my sidepipes and extra set of J-pipes. Still look like new after solid year on the road.

Doug
FFR2625
 

·
Registered
Joined
·
110 Posts
Duane:
What kind of motor and trans mounts are you using? How are your side pipes hung? Is the break in the heated area right next to the weld? As I recall others have experienced a spiral crack in the J-pipes also.

RIP
 

·
Administrator
Joined
·
9,772 Posts
Get rid of those things!!! I bet MDM could make a j-pipe in minutes.

[ November 22, 2002, 12:48 AM: Message edited by: Bill ]
 

·
The Traveler
Joined
·
3,104 Posts
Yup broke 2 of them so far. Finally traced it to the side mounts. The engine twists down and to the right. My original donot motor mounts allowed the engine to REALLY twist down. So the only place for a little give was the cats! I finally figured out what was happening and bought some poly mounts. That has solved my problem as before I'd crack a right hand cat in about 20,000 miles. Now I've had my current ones on for over 60,000 with no more problems.

I think it also contributed to the breaking off of the side pipe hanger so why your at it check that too!
 
1 - 8 of 8 Posts
Top