Factory Five Racing Forum banner
1 - 5 of 5 Posts

·
Banned
Joined
·
2,257 Posts
Discussion Starter · #1 ·
I've got Mike Forte's 400 HP 351W. The oil pan is stock and doesn't have a separate bong for the temp. sensor.

For those of you who've used Autometer Vintage gauges, is there any problem with using the threaded adapter sleeve they provide with the gauge to install the oil temperature sensor in place of the oil pan drain plug?

I was wondering whether the wiring and connecter protrude so far down toward the ground that they might be vulnerable to being broken or knocked off from road hazards ?
 

·
Junior Charter Member
Joined
·
90 Posts
If you try that, I would really worry about the sensor getting knocked out and spewing hot oil all over the track or road causing those behind you to spin and crash. I've seen it and it ain't pretty. I have the FFR remote oil filter adapter on my 351W and the aluminum adapter on the engine sits next to the oil pressure sensor so I was able to take out one of the threaded plugs from the unused port and screw in an adapter for the 1/8" NPT on the oip temp sensor. Seems to work fine and the grounding thru the threads is adaquate.
Elapid
 

·
Charter Member
Joined
·
2,035 Posts
Sherrell, same engine had same issue. I talked to Mike and he has a plate that mounts between the oil filter and block with a bung in it for the oil temp sensor. I am waiting for my first oil change to install it. HTH.
 

·
Banned
Joined
·
2,257 Posts
Discussion Starter · #4 ·
Jeff,

Great you jumped in. I was wondering today about access to the oil filter and whether to leave it original or relocate with the kit parts. What did you do?

After you add the plate from Mike, will you still have enough room to get the filter on and off without buggering up the frame?

Sherrell
 

·
Charter Member
Joined
·
2,035 Posts
Sherrell,

I have the FFR 4x4 headers so my filter is in the stock location. I don't see an issue with clearance. The plate seems like it will add about 1 1/2" between the block and filter when installed. Might bring it a bit closer to the header if anything. The stock filter is the tall one and I have seen guys run a shorter filter but I'm really not seeing an issue anyway. I'll be at work until about midday on Sun and could snap a pic of my current setup (without) an/or the plate uninstalled if it would help you.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top