Factory Five Racing Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
309 Posts
Discussion Starter · #1 ·
My first fan lost a blade three or four starts of the motor in. This time I had almost 400 miles on it.
When it broke this time I had just brought the the speed of the car up to about 100 mph for the for time.All of the sudden I smell the coolant . I limp to work and see the leak on the back side of the radiator.When I got home and removed the fan to get the radiator out I noticed the fan was missing a blade.

I was thinking of going with another type of set-
up. Maybe a dual fan of smaller diameters.

What has worked best for you?
 

·
Senior Member
Joined
·
3,645 Posts
is that another spal? I put rubber spacers in mine and have not had a problem (running it in the garage)
 

·
Registered
Joined
·
309 Posts
Discussion Starter · #5 ·
Both fans were installed as per manual. I have heard of people putting in spacers to get the blades farther from the brackets,but I don't think that was the issue this time. It was my first high speed run and it broke during acceleration at about 100mph. If anything the blade would have been farther away from the bracket because of the airflow coming thru at those speeds. I just looked at a nice 16" perma-cool electric fan with metal blades. It looks beefier.
 

·
Registered
Joined
·
28 Posts
Mike,
IF you're using the fan supplied with the kit IT IS CRAAAAAPPPP. I HAD THE SAME ISSUE AND DECIDED TO GO WITH A FAN REINFORCED AROUND THE OUTSIDE OF THE BLADES.I HAVE NOT HAD ANY PROBLEM SINCE. WORD TO THE WISE. THROW IT IN THE TRASH !!!! AND SAVE YOUR RADIATOR 1111
 

·
Junior Charter Member
Joined
·
371 Posts
With all the posts on here about this problem... What is FFR doing about it. I'm afraid to install mine now. Bad enough you have to buy another fan... but a another radiator as well????I think FFR should offer a FULL refund for all fans not yet installed!
Dennis
 

·
Senior Charter Member
Joined
·
3,272 Posts
The Derale fans are very good also, Have had mine for almost 3000 miles and no problem.
All the blades are connected so they don't flex like the spal fan. What ever you do don't put another spal on it. It has already done more damage than it should of.
Todd
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top