Need Opinions on Engine trouble - FFCars.com : Factory Five Racing Discussion Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-26-2016, 02:53 PM Thread Starter
OK, I'm In!
 
*El Ocho 1*'s Avatar
 
Join Date: Jun 2009
Location: Miami, FL
Posts: 227
Need Opinions on Engine trouble

OK guys, been a while since I've posted....Need your expert help.

In the 6 years I've own the Cobra it's run just fine. Worse problem I had was a throttle cable that snapped.

I just sold it a few weeks ago, but I still have it in my possession trying to iron out some issues it just started having.

The engine is a Ford 302 w/ a Holley 670.

So I meet the buyer & we do the title transfer & all & when he comes back from a drive around the block & goes start it again it wont crank, battery seems low. We get a jump & it starts right up, but he ask me to get him a new battery. Sure, no problem. On my way home with it (his car now), while at a light my tach starts jumping up & down like crazy & she just turns off. I though alternator maybe.....so I got another jump but this time it wont start. just turns & turns, but wont crank. So I think spark.....

I remove distributor cap & see that the rotor contact is worn & contacts on cap are all corroded. I tow it back home & order new MSD cap & rotor.

So yesterday & start it up & it's running ok. Did notice a small pop (misfire or backfire) at around 3000 rpms, but other than that it's running pretty good. I'm taking it to the buyers storage unit & 2 blocks away it just dies as I'm driving. I coast to the side of the road & again, she wont crank, engine just turns & turns.

I'm thinking that maybe the MSD Ignition control box is going bad. I tested it before, when I changed cap & rotor & I was getting spark from the coil & I also tested the magnetic pick up & although it's pretty rusty it was showing 580 ohms.

But I've been reading that those 6A MSD Boxes sometimes just up & die.

What do you guys think? Any opinions or help would be greatly appreciated. I want to give this gentleman a car running like it should be, so I need to get this fixed.

Thanks in advance


FFR MKIII #5089

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
*El Ocho 1* is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-27-2016, 01:04 AM
Charter Member
FFCars Master Craftsman
 
DWIGHT's Avatar
 
Join Date: Jul 2002
Location: FLORENCE, ALABAMA
Posts: 1,746
yes MSD boxes do die. Sometimes slowly.

Dwight


RCR GT 40, 347 with Eight Stack Injection system with 0 miles
1966 Ford Fairlane GT 2 door hardtop with 390 5 speed.
DWIGHT is offline  
post #3 of 5 (permalink) Old 05-27-2016, 11:42 AM
Junior Charter Member
 
Cobra4GC's Avatar
 
Join Date: May 2007
Location: Sugar Hill, GA
Posts: 221
Have you verified the magnetic pickup in the dizzy is good? I had this problem a year ago as I had no spark which started out very intermittent. MSD has good troubleshooting procedures on their website. it is an easy procedure to check. The magnetic pickup is something that is easily overlooked so a quick resistance (ohms) check can tell you if it is bad or possibly broken. Mine was broken in half.

HTH,

Gary

Viper Graphic Metallic w/Silverstone strips by Whitby's, Levy Stage 5 408W, Levy Super Alloy T5, Mid shift, Forte’s hyd clutch, CNC reservoirs, Team III wheels, IRS w/3.55 gears, Sube seats, Classic Instruments, Russ Thompson turn signal, Dual Roll Bars, Whitby roll bar bezels, DrummerMike heat shields, GAS-N SS pipes, Ron Davis dual fan radiator, Finish Line Rear View Mirror, Breeze billet side mirrors, SAI Mod, Herbs door panels
Cobra4GC is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 05-27-2016, 02:44 PM Thread Starter
OK, I'm In!
 
*El Ocho 1*'s Avatar
 
Join Date: Jun 2009
Location: Miami, FL
Posts: 227
Quote:
Originally Posted by Cobra4GC View Post
Have you verified the magnetic pickup in the dizzy is good? I had this problem a year ago as I had no spark which started out very intermittent. MSD has good troubleshooting procedures on their website. it is an easy procedure to check. The magnetic pickup is something that is easily overlooked so a quick resistance (ohms) check can tell you if it is bad or possibly broken. Mine was broken in half.

HTH,

Gary
yeah, I did. Although it looks all rusty, it was showing about 580 ohms, which is right in the range MSD suggest.

Quote:
Originally Posted by DWIGHT View Post
yes MSD boxes do die. Sometimes slowly.

Dwight
I think that's what's happening.

BTW, PM replied

FFR MKIII #5089

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
*El Ocho 1* is offline  
post #5 of 5 (permalink) Old 05-29-2016, 12:51 PM
Senior Member
FFCars Master Craftsman
 
turbodon's Avatar
 
Join Date: Aug 2002
Location: Manteca, CA
Posts: 2,602
So did you change the battery? I see you state no problem but do not read where you changed the battery.

MSD'd need a certain minimum voltage or they will not fire. So a dead under voltage battery can cause this symptom.

If you did change the battery and the alternator is keeping a charge, then I would look else where. There are many ways of testing an MSD. google....

MSD - Testing Ignition Box » Video | O'Reilly Auto Parts

https://www.msdperformance.com/suppo...ng_techniques/
turbodon is online now  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the FFCars.com : Factory Five Racing Discussion Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome

 

Welcome to FFCars! The representations expressed are the representations and opinions of the FFCars.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners, moderators, Factory Five Racing, Inc. or Ford Motor Company. This website has been planned and developed by FFCars.com and its forum members and should not be construed as being endorsed by Factory Five Racing, Inc. or Ford Motor Company for any purpose. "FFR", "Factory Five", "Factory Five Racing", and the Factory Five Racing logo are registered trademarks of Factory Five Racing, Inc. FFCars.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). Thank you for visiting the FFCars.com Forum dedicated to Factory Five.