Video showing My FiTech GoStreet EFI 400 Wiring - FFCars.com : Factory Five Racing Discussion Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-26-2017, 03:51 PM Thread Starter
Senior Member
FFCars Craftsman
 
DadofThree's Avatar
 
Join Date: Sep 2012
Location: Tybee Island, GA
Posts: 790
Video showing My FiTech GoStreet EFI 400 Wiring

Last night I spent the time wiring up my FiTech and thought I'd share with you what I did. It's probably a better idea to do this after a clean start, but none the less.....Please take a look and tell me if I've done anything wrong.

Thanks.
Dave




--------------------------------------------------------------
Dave
Greenhorn / A New Experience for Me.
Mk 3.1 - #6882 - 5.0L 302 - FiTech EFI - 3-Link - 3.08 Ratio - 15" Wheels

Purchased 10/7/15; Brought her Home 10/18/15
My photos are at:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Videos are at:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My Build (Learning as I go and poorly organized) Blog @
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

--------------------------------------------------------------
Loving the Island Life


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DadofThree is online now  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-26-2017, 09:45 PM
Senior Member
 
Join Date: Nov 2013
Location: Manahawkin, NJ
Posts: 124
Nice video, just finished this install today. I used the choke wire for the key-on power like you are considering since it was already up next to my carb.
I also used the RF fan control wire that was on the intake since all it does is ground the relay when it reaches temp, which is the same function that fitech does.
I have a diff ignition set up than you, so I pulled the tach off the back of the tach, which is fed from an MSD box. fitech says this is okay to do.
Red power wire went to the battery feed that goes to the key, since it was right there and easy to tap into.
Fuel pump power - was gonna run it back to the tank direct to use modulation feature, but didn't want to tear apart my tunnel harness. I just ran it to the pump relay in the fuse box as designed in the RF harness.
Turned the key and it worked, so I can at least confirm that you are good to go on the choke wire part! Good luck this weekend!


MK IV # 8639 Delivered June 2015 - SBF 347 w/450hp, FITECH 30002, Levy SA T5, 3 Link w/ 3.55's, cobra discs, manual brakes/steering
Keysergogo is online now  
post #3 of 5 (permalink) Old 05-27-2017, 01:17 AM Thread Starter
Senior Member
FFCars Craftsman
 
DadofThree's Avatar
 
Join Date: Sep 2012
Location: Tybee Island, GA
Posts: 790
Quote:
Originally Posted by Keysergogo View Post
Fuel pump power - was gonna run it back to the tank direct to use modulation feature, but didn't want to tear apart my tunnel harness. I just ran it to the pump relay in the fuse box as designed in the RF harness.
Turned the key and it worked, so I can at least confirm that you are good to go on the choke wire part! Good luck this weekend!
I'm glad to hear you had a successful go at it. I too did the suggested step by RF for the EFI controlling the pump this evening. I cut the little pig tail located at the relay and attached the orange wire to it.








--------------------------------------------------------------
Dave
Greenhorn / A New Experience for Me.
Mk 3.1 - #6882 - 5.0L 302 - FiTech EFI - 3-Link - 3.08 Ratio - 15" Wheels

Purchased 10/7/15; Brought her Home 10/18/15
My photos are at:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Videos are at:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My Build (Learning as I go and poorly organized) Blog @
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

--------------------------------------------------------------
Loving the Island Life


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DadofThree is online now  
 
post #4 of 5 (permalink) Old 05-27-2017, 02:53 AM
Senior Member
FFCars Craftsman
 
brian1967's Avatar
 
Join Date: May 2005
Location: Bucks county, Pa
Posts: 835
Looks good Dave. When I connected the Fitech 12 volt input lead to the starter I had a problem where the Fitech screen would go black upon cranking and I would have to unplug the controller pigtails at the controller to bring it back up. Fitech tech line told me it needs to go directly to the battery. I did just that and problem solved. And that vacuum nipple on the passenger side of the throttle body is for fuel pressure boost refrence, used only if your running a turbo or supercharger. leave it open since your not going that route, don't even cap it.

Remember to have the o2 sensor plugged in before you turn the key, Fitech states it can damage the computer if left unplugged. ( even just with the key on and not running).

Good luck, I cant wait for the video.
brian1967 is offline  
post #5 of 5 (permalink) Old 05-27-2017, 09:33 PM Thread Starter
Senior Member
FFCars Craftsman
 
DadofThree's Avatar
 
Join Date: Sep 2012
Location: Tybee Island, GA
Posts: 790
Note: I didn't habe spark until I ran the orange efi crank wire to the positive coil post. Also, I ended up skipping the fuel pump relay and hardwired the orange fitech wire directly to the fuel pump wire. Then we got fuel.
DadofThree is online now  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the FFCars.com : Factory Five Racing Discussion Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome

 

Welcome to FFCars! The representations expressed are the representations and opinions of the FFCars.com forum members and do not necessarily reflect the opinions and viewpoints of the site owners, moderators, Factory Five Racing, Inc. or Ford Motor Company. This website has been planned and developed by FFCars.com and its forum members and should not be construed as being endorsed by Factory Five Racing, Inc. or Ford Motor Company for any purpose. "FFR", "Factory Five", "Factory Five Racing", and the Factory Five Racing logo are registered trademarks of Factory Five Racing, Inc. FFCars.com forum members agree not to post any copyrighted material unless the copyrighted material is owned by you. Although we do not and cannot review the messages posted and are not responsible for the content of any of these messages, we reserve the right to delete any message for any reason whatsoever. You remain solely responsible for the content of your messages, and you agree to indemnify and hold us harmless with respect to any claim based upon transmission of your message(s). Thank you for visiting the FFCars.com Forum dedicated to Factory Five.